Service Degradation - Multiple countries
Resolved
This incident has been resolved.
Posted Jan 02, 2025 - 22:36 UTC
Monitoring
Thank you for your patience.
We're pleased to inform you that the network service has been successfully restored. Can you please try restarting your device and see if you notice an improvement?
Please contact us promptly in case the issue persists for you.
Posted Jan 02, 2025 - 19:20 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jan 02, 2025 - 18:17 UTC
Identified
Unfortunately, we have confirmed that we are experiencing a temporary service degradation issue preventing users from connecting.
We are working with our partner to fix this as soon as possible so users can enjoy the service they deserve.
We understand the inconvenience this may cause and sincerely apologize for the disruption. Our users' experience is our top priority, and we hope to connect them again shortly.
We will let you know as soon as there is an update.
Thank you for your kind understanding and patience.
Posted Jan 02, 2025 - 17:42 UTC
This incident affected: Regional eSIMs (Eurolink (Europe), Latamlink (Latin America), Menalink (Middle East and North Africa)) and Local eSIMs (Arpi Telecom (Armenia), Pico (Azores), Jitney Mobile (Bahamas), Norach Telecom (Belarus), Belganet (Belgium), Paro (Bhutan), WA Mobile (Bolivia), Joia (Brazil), Muara Mobile (Brunei), Mansetel (Canary Islands), Atlantis Telecom (Cayman Islands), Chinacom (China), Hartonet (Colombia), Cronet (Croatia), Bacanet (Ecuador), Giza Mobile (Egypt), Bonbon Mobile (France), Kargi Mobile (Georgia), Hallo! Mobil (Germany), Szia! (Hungary), Nenna Mobile (Iceland), Indicomm (India), Indotel (Indonesia), Babel Mobile (Iraq), Fáilte (Ireland), Jornet (Jordan), Liberation Mobile (Kuwait), Pak Ou Mobile (Laos), Labitel (Latvia), Lila Mobile (Lithuania), Luxcom (Luxembourg), Madeira (Madeira), Chorro Fon (Mexico), Jezero (Montenegro), Choukran (Morocco), Patancell (Nepal), Nzcom (New Zealand), Nicarcell (Nicaragua), Lofotel (Norway), Omancom (Oman), Tine Mobile (Palestine, State of), Pancell Digital (Panama), Triple Communications (Paraguay), Habla Telefon (Peru), Pearl Mobile (Qatar), Red Sand (Saudi Arabia), Nessietel (Scotland), Connect Lah! (Singapore), Dobrý deň! (Slovakia), Živjo (Slovenia), Guay Mobile (Spain), Vän (Sweden), Jaco Mobile (Timor - Leste), Merhaba (Turkey), Burj Mobile (United Arab Emirates), Uzbeknet (Uzbekistan), Ager (Vatican City), Aragua Mobile (Venezuela)).